[Bug] Kill X of Y quests

Right now, I’m on the infamous screecher’s quest in upper ground, and for the life of me, I couldn’t find the last screecher. I spent well over a hour (across days, nearly gaining a full level) just hunting down #20. I finally found him, but he’s in a place that I can’t reach–I tried everything, throwing swords at him, using splash weapons on the wall, everything, and I can’t kill it. I tried suggestions I found on other forums, like using a prd and waiting a while before I came back in hopes it would spawn right, but nothing.
What do you do in a situation like this? I can’t continue my quest line because of it.

Sometimes the only thing you can do when this happens is to abandon the quest and then take it from the NPC again. You’ll have to start from 0/20 screechers but it doesn’t take long to run the quest again.

1 Like

I’ll have to give that a try then. I’m just worried that there will be kill 200 quests later, or something like that…

There’s nothing that big thank goodness!

Womp womp, no luck. One always spawns unreachable :confused: