Bug: "Minimum System Requirements Not Met"

First of all, thanks for creating this, and allow me to play it. As primarily a single player kind of guy I only played the single player version of the game at its original release, and as such I never got to experience Stonehenge and The Abyss, since those never made it to single player. I’m looking forward to finally checking them out, and I’ve enjoyed the little bit I’ve played so far.

In any case, the reason I made this topic is to report a bug. Not sure if you can (or even should bother) to try to fix it, but if it’s easy for you to do, then I wouldn’t mind. You see, every time I start the game I get this error message:
image

I run on an Intel i7 4790k, slightly overclocked at 4.3GHz, with a GTX 980 graphics card, so I’m sure I meet the system requirements just fine. :slight_smile: But for some reason the hardware check for the game only detects the lowest frequency the processor will run at, when idle, and gives this error message. Of course, I can simply click through it and play with no problems at all, but if it’s easy to remove it would be nice not to have to. Besides, 10 years after the initial release, I doubt there are many, if any, that would try to run this game on a processor that DIDN’T match that spec, so doing a check for it now almost seems redundant, IMO.

I think you should check your overclocking profile, and set the “minimum bar” higher.
I don’t overclock my processor, just checked what happens when i start the game when my CPU drops below 800 MHz and it automatically turns on performace mode immediately, so i didn’t get this message.

I’m not quite sure how to do that.

In any case, the CPU speed isn’t the problem; it immediately goes up to the maximum turbo speed (4.4GHz) when I start the game, but the message pops up all the same. The reason for the message is most likely that Windows 10 falsely detects the CPU speed when it’s overclocked (and the ASUS motherboard I use pretty much insists on overclocking by at least 8% by default); even in Task Manager it reports its speed at 800MHz, even when it runs at 4.4GHz. That problem in itself gave me a hell of a time once when I tried to upgrade Windows 10 to Creator’s Edition some months ago, as the manual setup refused to run on what it detected as a too slow CPU.

In other words, Windows is to blame for error messages occurring when something queries for the CPU speed, but does the game really need to query?