SEA region version


#1

Hello I’m new here.I do have a retail copy of Hellgate london but It’s SEA region
Can I play on this server? I trie to install but I cant install patch.


#2

If the patch you’re talking about is the MP 2.0 patch, and it isn’t working, then maybe your copy isn’t compatible. If the 2.0 patch installed successfully, you may have to convert your installation using this guide before the 2038 launcher will work properly.


#3

It said my installation (hanbitsoft_se_asia) is not supported by this patch :frowning:
I think I should let this game go
Thanks for help btw :slight_smile: